圣诞怪杰--比“破壳”更严重的漏洞惊现
作者:星期五, 十二月 19, 20140

4.JPG云安全公司Alert Logic的研究人员发现Linux系统存一个严重漏洞,可以被攻击者利用获得root权限,该漏洞被称为“圣诞怪杰”(Grinch)。

Grinch影响所有Linux系统,包括Web服务器和移动设备。它是由Polkit相关的普通配置问题引起的。Polkit是类Unix操作系统中一个相对比较新的组件,用于控制系统级的权限。

与把系统权限赋予给某个用户的Sudo命令不同,Polkit可以限定用户及操作的界限,以及定义用户如何执行操作。

提权的操作通过“wheel”组来完成,wheel是一个特殊的具有管理权限的用户组。在Linux系统中,默认的用户会自动被分配到这个组。

问题存在于两个地方。一是许多Unix系统默认的Polkit配置,并不需要授权;二是Polkit的配置会映射Wheel用户组,而这个用户组通常是Sudo指派admin权限的用户。因此,wheel组中的用户能够使用管理权限进行操作,如无需口令即可安装程序包。这一点意味着Grinch也许比破壳(Shellshock)更加危险。

Grinch不仅影响大多数的家庭用户,而且还会影响企业用户,因为后者由于各种原因通常都会把用户指派到wheel组中。

在该漏洞的补丁发放之前,可以正确的设置Polkit和用户组权限的授权规则以防止Grinch的攻击。

关键词:

申明:本文系厂商投稿收录,所涉观点不代表安全牛立场!


相关文章

没有相关文章!