英国NCSC将发布Nmap脚本,帮助查找未打补丁的漏洞
作者: 日期:2022年02月08日 阅:1,413

日前,英国国家网络安全中心(NCSC)宣布将发布NMAP脚本引擎脚本,这套脚本可以帮助防御者扫描其基础设施,以查找和修复未打补丁的漏洞。这些脚本将通过一个名为Scanning Made Easy(SME)的项目发布在GitHub上。项目描述显示:“Scanning Made Easy(SME)是i100与NCSC合作的一个项目,旨在构建一套NMAP脚本引擎脚本,目的是帮助系统所有者和管理员找到存在特定漏洞的系统。”

NCSC表示:软件漏洞被披露后,找到可以利用它的概念验证代码常常比找到有助于防护企业网络的工具来得容易。而更糟糕的是,即使有扫描脚本可供使用,也很难知道脚本是否可以安全地运行,更不用说脚本是否会返回有效的扫描结果了。我们因这个问题而倍感沮丧,并且希望帮助网络防御者找到易受攻击的系统,以便他们能够保护系统,Scanning Made Easy(SME)于是应运而生。

NCSC批准行业合作伙伴提交脚本,前提是要看脚本是否满足以下强制性要求:

1. 使用NMAP脚本引擎(.nse)为NMAP编写;

2. 涉及影响英国的某个高优先级漏洞;

3. 符合元数据模板;

4. 在孤立环境下运行,即没有依赖项,不连接到其他服务器;

5. 检测易受攻击的实例时可靠性尽可能接近100%,即低误报率;

6. 检测机制中尽可能不干扰(即不传输过多的网络流量)、尽可能安全;

7. 托管在公开可用的代码存储库或网站上;

8. 采用宽松式开源许可证,免费提供;

9. 不获取敏感数据,比如暴露网络安全风险或个人信息;

10. 不从运行脚本的系统发送数据;

11. 能够将脚本的输出写入到文件。

如果合作伙伴已将脚本上传到公开可用的代码存储库或网站,可以联系NCSC核查脚本,评估后通知社区,并附以链接。目前,NCSC已经发布了第一个SME脚本,让Exim电子邮件服务器软件的维护者可以解决总共21个漏洞(这些漏洞统称为21Nails),攻击者此前可以利用这些漏洞接管服务器,并通过服务器访问电子邮件。

参考链接:

关键词:


相关文章