IoT“永恒之蓝”来袭:路由器等智能硬件成重灾区

作者:星期五, 五月 26, 20170
分享:

肆虐全球Windows设备的“永恒之蓝”勒索病毒攻击余波未平,一个Linux版的“永恒之蓝”又出现了。

5月25日凌晨,360官方博客紧急发布了Samba远程代码执行漏洞警报(CVE-2017-7494)。Samba是在Linux和Unix系统上实现SMB协议的开源软件,正广泛应用在Linux服务器、NAS网络存储产品,以及路由器等各种IoT智能硬件上。

与Windows版的“永恒之蓝”相比,Samba漏洞相对比较简单、更容易被攻击,而且同样威力巨大,可以远程执行任意代码。其漏洞攻击工具也已在网上公开,很可能被不法分子恶意利用。

对普通个人用户来说,Samba漏洞会对各种常用的智能硬件造成严重威胁。例如,全球流行的路由器开源固件OpenWrt就受到Samba漏洞影响,可能导致路由器被黑客控制,劫持或监听网络流量,甚至给上网设备植入木马。此外,包括智能电视等设备中,Samba文件共享也是常用的服务。

针对各类智能硬件用户,360安全卫士建议用户及时关闭路由器、智能电视等设备的Samba文件共享服务,等待固件进行安全更新后再开启Samba。

针对使用Samba的服务器管理员,360网络安全响应中心和360Gear Team经过分析评估后,第一时间发布了漏洞解决方案,建议参考以下方式进行安全更新:

  • 使用源码安装的Samba用户,请尽快下载最新的Samba版本手动更新;
  • 使用二进制分发包(RPM等方式)的用户立即进行yum,apt-get update等安全更新操作;

如果暂时无法升级Samba的版本,用户还可以通过在smb.conf的[global]节点下增加 nt pipe support = no 选项,然后重新启动samba服务的操作,达到缓解该漏洞的效果。

 

分享:

相关文章

写一条评论

 

 

0条评论